Справка по программе СитиГИД
 Top Next
Данное описание представляет собой краткий справочник по интерфейсу и меню программы СитиГИД версии 5.0 для Windows Mobile и Windows CE.


Интерфейс программы
 Previous Top Next

Основную часть экрана занимает карта. Поверх карты отображаются кнопки, индикаторы режимов работы, текстовая информация (например, время и дата), навигационная панель.

Вид экрана при заданном маршруте:

Вид экрана без задания маршрута:

Основные управляющие элементы:
1. Индикатор сигнала сотовой сети.
2. Индикатор заряда батареи.
3. Текущие дата и время.
4. Индикатор обновления информации о пробках.
В режиме с заданным маршрутом - зеленый телефон - связь с интернетом есть, красный - нет. Стрелка индикатора показывает степень актуальности данных о пробках (чем выше стрелка - тем "свежее" информация). Когда стрелка достигает нижнего положения - программа устанавливает связь с сервером и загружает новые данные.
В режиме "без маршрута". Зеленый кружок - пробки получены, желтый - идет сеанс связи, красный - ошибка связи с сервером.
5. Компас (в режиме "без маршрута)
6. Индикатор уровня сигнала GPS.
В режиме с заданным маршрутом - при наилучшем сигнале - стрелка вверху, индикатор зеленый. При наихудшем - стрелка внизу, индикатор красный. При отсутствии сигнала - вместо индикатора отображается красный крестик.
В режиме "без маршрута" - красная/зеленая шкала.
7. Кнопки изменения угла наклона карты. Они присутствуют только в режиме "Перспектива" ("3D").
8. Кнопка переключения режима "Карта (2D)"/"Перспектива (3D)".
9. Кнопки изменения масштаба отображения карты.
10. Индикатор масштаба.
11. Кнопка Финиш - позволяет выбрать точку финиша (из Фаворитов, Закладок, Мест интереса (POI), либо выбрать адрес или перекресток)
12. Кнопка доступа к Главному меню .
13. Кнопка доступа к Быстрому меню (меню, в которое можно назначить наиболее востребованные функции)
14. Кнопка отправки сообщений (DPOI).
15. Текущая скорость.
16. Название следующей улицы (на которую планируется ближайший поворот)
17. Индикатор второго маневра (следующего за ближайшим) и расстояние между ними.
При нажатии на значок маневра выводится "слайд-шоу" - просмотр поворотов по маршруту.
18. Индикатор выбранного типа маршрута .
Оптимальный - оптимальный
Кратчайший - кратчайший
Экстренный - экстренный
Пешеходный - пешеходный
Внедорожный - внедорожный.
19. Индикатор ближайшего маневра. Плавный поворот отображается зеленой стрелкой, крутой поворот (круче прямого угла) - оранжевой. Серыми линиями показаны другие дороги на этом перекрестке, красными - направления, проезд по которым запрещен.
Вокруг индикатора маневра вращаются маленькие стрелки - компас.
Нажатие на индикатор маневра выводит легенду маршрута - список поворотов, названия улиц и расстояние до них.
Легенда пролистывается автоматически, но можно проматывать ее вручную.
20. Ярлычок для включения функции "Север сверху"
21,22. Время и расстояние до конца маршрута. При нажатии на эту область, если маршрут задан с промежуточными точками, отображается время и расстояние до ближайшей промежуточной точки. Клетчатый флажок (финиш) в данном поле при этом заменяется желтым (промежуточная точка).
23. Индикатор текущего положения ("Дельтаплан"). Красная точка обозначает положение, определенное по сигналам GPS, "Дельтаплан" - скорректированное положение с учетом привязки к дорогам и скорости движения.
24. Регулировка скорости проигрывания маршрута (отображается только в режиме симуляции (Меню-Маршрут-Проиграть)).
25. Расстояние до ближайшего маневра. Автомобиль, нарисованный рядом, никакой полезной информации в себе не несет.

При желании можно скрыть следующие элементы:
Экранные кнопки 7, 8, 9.
Нижнюю панель (11,13,14)
Время и дата
Скорость .
Масштаб .

В середине нижней части экрана (над названием текущей улицы) может, в зависимости от режима работы, отображаться "многофункциональная кнопка":
- Вызов контекстного меню для действий с точкой (показывается при нажатии точки на карте, если в Меню-Карта-Еще- Контекстное меню выставлено значение "по кнопке").

- Включить GPS приемник (показывается, если пользователь отключил GPS).
- Отключить режим "Стоянка" (показывается, когда пользователь выбрал режим в Меню-Функции-Стоянка). Режим "Стоянка" отключается астоматически при достижении скорости 20 км/ч.
- Возврат к текущему положению. Отображается, когда пользователь сдвинул карту и используется для возврата к отображению текущего положения в центре экрана.


Работа с программой


Простейший маршрут
Самый простой и быстрый способ прокладки маршрута - с помощью кнопки "Финиш".
Нажатие этой кнопки выводит на экран меню, позволяющее выбрать, какой объект использовать как точку финиша:

Фавориты - выбор из избранных закладок (фаворитов).
Закладки - выбор из сохраненных точек (закладок).
Улица, Адрес - ввод адреса или названия улицы.
Перекрестки - поиск перекрестка двух улиц.
Места интереса - поиск объектов в базе данных (POI).
Последние 10 - повторить один из 10 последних поисков.

Пункт Фавориты аналогичен одноименному пункту главного меню , остальные - соответствующим пунктам меню Поиск . Отличие в том, что после выбора точки (адреса, перекрестка, POI) не выдается меню Действие (Старт, Финиш, Промежуточная точка и т.д.), а сразу устанавливается точка финиша.

Финиш можно указать также прямо на карте.
1. Позиционировать карту так, чтобы нужная точка была на экране. Если известны ориентиры рядом с точкой, то для этого можно воспользоваться пунктом меню Поиск , выбрать нужный объект (улица, адрес, POI), а затем в открывшемся меню действий выбрать "показать".
2. Нажать (это действие называют также "тапнуть", от английского tap) нужную точку на экране. В зависимости от настройки пункта Контекстное меню , может потребоваться "длинный тап" или последующее нажатие на кнопку с изображением прицела.
3. В появившемся контекстном меню выбрать пункт Финиш маршрута.


Маршрут с промежуточными точками
Для создания маршрута с промежуточными точками, очевидно, необходимо задать финиш и промежуточные точки.
Точки задаются аналогично финишу - либо через меню Поиск, либо с помощью контекстного меню.
СитиГид не оптимизирует порядок объезда точек, поэтому, если Вы не уверены, лучше посмотреть расположение точек на карте и спланировать порядок их объезда. Если все же ошиблись, проложенный маршрут можно скорректировать.
В меню Маршрут-Изменить точки (включая финиш) можно менять местами, обеспечивая оптимальный порядок их проезда.
Точку финиша можно задавать как до промежуточных точек, так и после них, и даже в середине процесса.
То есть можно задавать их в таком порядке:
Точка1, точка2, финиш, точка 3.
Маршрут построится в порядке:
Точка1, точка2, точка3, финиш.
Если при вводе точки финиша уже имеются введенные промежуточные точки, выдается запрос - "Удалить пром.точки или нет?".


Редактирование маршрута
Для изменения точки финиша надо просто задать новый финиш.
Новую промежуточную точку можно добавить в любой момент.
Удалить промежуточную точку можно либо с помощью контекстного меню, нажав на нее и выбрав "Удалить точку", либо через меню Маршрут-Изменить .
В движении для изменения маршрута достаточно просто поехать по тому пути, который кажется Вам более удачным. СитиГид пересчитает новый маршрут (с учетом проезда всех оставшихся непройденными промежуточных точек) исходя из Вашего нового положения и направления.
Маршрут можно сохранить, а затем загрузить.
Пример: вам надо утром куда-либо ехать, но по дороге надо забрать трех друзей из разных точек. Чтобы утром не тратить время на поиск четырех адресов, можно сделать это с вечера и сохранить маршрут (причем можно это сделать даже дома, при отсутствии сигнала GPS). Сохраняются только промежуточные точки и финиш. После загрузки маршрута утром и определения координат СитиГид проложит оптимальный маршрут.


Маршрут на диване
Если требуется проложить маршрут не из Вашего текущего положения, а из какой-то другой точки, то для маршрута надо задать точку старта.
Старт задается аналогично промежуточным точкам - либо через контекстное меню (нажатием на экран), либо через меню Поиск .
Задать точку старта можно в любой момент (первой из всех точек, последней, или в середине).
При определении программой координат точка старта автоматически переносится в текущее положение. Поэтому для прокладки маршрута с использованием точки Старт целесообразно отключить GPS-приемник .
При планировании маршрута в отсутствие сигнала GPS (например, в помещении) GPS-приемник можно не отключать. При закрытии программы маршрут будет сохранен. При следующем запуске программы он снова будет проложен, но уже из точки текущего положения.


Главное Меню
Это краткое описание меню программы СитиГид.
Составлено для версии 5.0 под Windows Mobile и Windows CE.
В зависимости от выбранного интерфейса (стандартный или упрощенный), меню может выглядеть по-разному, но отличие только в форме кнопок и их оформлении.


Фавориты
Фавориты - это меню избранных закладок, аналог быстрого набора в телефоне. Если у Вас несколько десятков закладок, то самые-самые нужные можно внести в "Фавориты" для их быстрого вызова.
В исходном варианте доступно восемь кнопок, в любительских скинах доступны более многокнопочные фаворит-меню.

Кнопки:
Меню - возврат в главное меню
Поехали - выход из меню, возврат на карту
Настроить - назначение закладок на экранные кнопки в меню Фавориты. Этот пункт полностью дублируется пунктом меню Настройки-Фавориты .
Для настройки надо нажать выбранную экранную кнопку и выбрать для нее закладку. По завершени настройки нажать кнопку "Закрыть" для возврата в меню Фавориты.


Поиск
Поиск объекта, адреса, перекрестка, точки по координатам и т.д.

Еще -
Убрать найденное - убрать с карты все указатели на объекты, найденные с помощью пунктов "Поиск-....-Показать (Показать все)". Целесообразно внести эту команду в Быстрое меню .
Выбирать карту при поиске - Если данная опция выбрана, то поиск объекта (адреса, POI и т.д.) осуществляется в пределах одной карты, что существенно ускоряет поиск.
Название активной карты и категории поиска выводится в верхней строке экрана (например "Санкт-Петербург-Магазины").
Если требуется выполнить поиск в другой карте, надо перейти к экрану выбора карты кнопкой "<<".
Если опция не выбрана, то должен производиться "сквозной" поиск - по всем картам. По ряду причин он не всегда работает корректно, поэтому рекомендуется установить данную галочку.


Все объекты
Поиск в названиях любых объектов на карте
1. Первый раз ввод адреса начинается с выбора карты. В последующие разы ввод начинается с выбора улицы (выбранная карта запоминается). При необходимости поиска адреса в другом регионе (на другой карте) нажать "<<" для выбора карты.
2. Выбрать расстояние до объекта (радиус поиска).
3. Набрать на клавиатуре часть названия объекта, или найти его в списке.
Для переключения языка ввода нажать "Eng" или "Рус", для ввода цифр "123". Если клавиатура мешает просмотру списка, ее можно убрать. Для этого надо просто "сдвинуть" ее пальцем вниз. Чтобы снова включить клавиатуру, надо нажать кнопку с изображением клавиатуры. Выбрав нужный объект, нажать ">>".
4. Старт - установить точку старта на выбранный объект (Если девайс находится в зоне приема сигнала GPS, необходимо предварительно отключить GPS в разделе Меню-Функции , в противном случае при определении своего местоположения программа установит точку старта в соответствии с GPS-данными).
Финиш - выбранный объект устанавливается как конечная точка маршрута.
Точка маршрута - выбранный объект является промежуточной точкой маршрута.
В закладки - Добавить выбранный объект в закладки.
Показать - Показать выбранный объект на карте. При этом выводится Окно предварительного просмотра.
Показать все - отобразить на карте все объекты списка, имеющие совпадение с введенным текстом.
Информация - просмотреть информацию о выбранном объекте (карта, категория, подкатегория, название, доп информация-чаще всего адрес)


Адрес
Поиск заданного адреса. Первый раз ввод адреса начинается с выбора карты. В последующие разы ввод начинается с выбора улицы (выбранная карта запоминается).
Обратите внимание, что название карты пишется в верхней части экрана.

При необходимости поиска адреса в другом регионе (на другой карте) нажать "<<" для выбора карты.
После ввода улицы нажать ">>" для ввода номера дома.
После ввода номера дома нажать ">>" для дальнейщего выбора:
Старт - установить точку старта на выбранный адрес (Если девайс находится в зоне приема сигнала GPS, необходимо предварительно отключить GPS в разделе Меню-Функции, в противном случае при определении своего местоположения программа установит точку старта в соответствии с GPS-данными).
Финиш - выбранный адрес устанавливается как конечная точка маршрута.
Точка маршрута - выбранный адрес является промежуточной точкой маршрута.
В закладки - Добавить выбранный адрес в закладки.
Показать - Показать выбранный адрес на карте. При этом выводится Окно предварительного просмотра.


Места интереса
Места интереса (Points of interest - POI) - база данных объектов.
1. Выбрать категорию объектов (АЗС, Магазиныи т.д.)
Для выбора подкатегории (если надо) нажать "Выбрать".
Чтобы вернуться из списка подкатегорий обратно к списку категорий, нажать "Наверх".
Выделив нужный раздел, нажать >>
2. Выбрать расстояние до объектов. Будет произведен поиск объектов, находящихся в заданном радиусе от текущего положения.
ВНИМАНИЕ! Пока не вышло исправление (5.0.SP1), следует выбирать "везде". При выборе любого расстояния выводится случайный набор объектов, а не выборка из заданной категории.
3. Набрать на клавиатуре часть названия объекта, или найти его в списке.
Для переключения языка ввода нажать "Eng" или "Рус", для ввода цифр "123". Если клавиатура мешает просмотру списка, ее можно убрать. Для этого надо просто "сдвинуть" ее пальцем вниз. Чтобы снова включить клавиатуру, надо нажать кнопку с изображением клавиатуры. Выбрав нужный объект, нажать ">>".
4. Старт - установить точку старта на выбранный объект (Если девайс находится в зоне приема сигнала GPS, необходимо предварительно отключить GPS в разделе Меню-Функции, в противном случае при определении своего местоположения программа установит точку старта в соответствии с GPS-данными).
Финиш - выбранный объект устанавливается как конечная точка маршрута.
Точка маршрута - выбранный объект является промежуточной точкой маршрута.
В закладки - Добавить выбранный объект в закладки.
Показать - Показать выбранный объект на карте. При этом выводится Окно предварительного просмотра.
Показать все - отобразить на карте все объекты списка, имеющие совпадение с введенным текстом. При этом выводится Окно предварительного просмотра.
При приближении к объекту, выбранному в пунктах "показать" или "показать все", будет выдаваться голосовое предупреждение "приближение к выбранному объекту"
Информация - просмотреть информацию о выбранном объекте (карта, категория, подкатегория, название, доп информация-чаще всего адрес)


Перекрестки
Поиск нужного перекрестка (по названиям двух улиц). Первый раз ввод адреса начинается с выбора карты. В последующие разы ввод начинается сразу с выбора улицы (выбранная карта запоминается). При необходимости поиска адреса в другом регионе (на другой карте) нажать "<<" для выбора карты.
1. Выбрать название первой улицы (для уменьшения списка набрать часть названия улицы на клавиатуре), нажать ">>" .
2. Аналогично выбрать название второй улицы, нажать ">>".
3. Старт - установить точку старта на выбранный перекресток (Если девайс находится в зоне приема сигнала GPS, необходимо предварительно отключить GPS в разделе Меню-Функции, в противном случае при определении своего местоположения программа установит точку старта в соответствии с GPS-данными).
Финиш - выбранный перекресток устанавливается как конечная точка маршрута.
Точка маршрута - выбранный перекресток является промежуточной точкой маршрута.
В закладки - Добавить выбранный перекресток в закладки.
Показать - Показать выбранный перекресток на карте. При этом выводится Окно предварительного просмотра. При приближении к показанному перекрестку будет выдаваться голосовое предупреждение "приближение к выбранному объекту".
Закрыть - возврат в меню Поиск.


Закладки
Поиск объекта из закладок - точек, сохраненных пользователем.
1.Набрать на клавиатуре часть названия закладки, или найти ее в списке.
Для переключения языка ввода нажать "Eng" или "Рус", для ввода цифр "123". Если клавиатура мешает просмотру списка, ее можно убрать. Для этого надо просто "сдвинуть" ее пальцем вниз. Чтобы снова включить клавиатуру, надо нажать кнопку с изображением клавиатуры. Выбрав закладку, нажать ">>".
2. Старт - установить точку старта на выбранную точку (Если девайс находится в зоне приема сигнала GPS, необходимо предварительно отключить GPS в разделе Меню-Функции, в противном случае при определении своего местоположения программа установит точку старта в соответствии с GPS-данными).
Финиш - выбранная точка устанавливается как конечная точка маршрута.
Точка маршрута - выбранная точка является промежуточной точкой маршрута.
Показать - Показать точку на карте. При этом выводится Окно предварительного просмотра. При приближении к показанной точке, будет выдаваться голосовое предупреждение "приближение к выбранному объекту"
Изменить - Переименовать закладку.
Удалить - Удалить закладку.
Закрыть - Возврат в меню Поиск.


Последние 10
Выбор одного из 10 последних выбранных объектов
После выбора оъекта нажать ">>" для дальнейщего выбора:
Старт - установить точку старта на выбранный адрес (Если девайс находится в зоне приема сигнала GPS, необходимо предварительно отключить GPS в разделе Меню-Функции, в противном случае при определении своего местоположения программа установит точку старта в соответствии с GPS-данными).
Финиш - выбранная точка устанавливается как конечная точка маршрута.
Точка маршрута - выбранная точка является промежуточной точкой маршрута.
В закладки - Добавить выбранную точку в закладки.
Показать - Показать выбранный объект на карте. При этом выводится Окно предварительного просмотра.


Города
Поиск населенных пунктов (применяется при путешествиях, когда Вы не знаете города, и ставите цель просто доехать до города, а там разобраться на месте).
Набрать на клавиатуре часть названия населенного пункта, или найти его в списке.
Для переключения языка ввода нажать "Eng" или "Рус", для ввода цифр "123". Если клавиатура мешает просмотру списка, ее можно убрать. Для этого надо просто "сдвинуть" ее пальцем вниз. Чтобы снова включить клавиатуру, надо нажать кнопку с изображением клавиатуры. Выбрав нужный населенный пункт, нажать ">>" для дальнейщего выбора:
Старт - установить точку старта на выбранный город (Если девайс находится в зоне приема сигнала GPS, необходимо предварительно отключить GPS в разделе Меню-Функции, в противном случае при определении своего местоположения программа установит точку старта в соответствии с GPS-данными).
Финиш - Выбранный город устанавливается как конечная точка маршрута.
Точка маршрута - Выбранный город является промежуточной точкой маршрута.
В закладки - Добавить выбранный город в закладки.
Показать - Показать выбранный город на карте. При этом выводится Окно предварительного просмотра.
Адрес - искать адрес в данном населенном пункте (переход в меню Поиск-Адрес ).


Координаты
Данный пункт позволяет найти точку по известным координатам.
Для ввода точки выбрать нужную координату (широту или долготу) и нажать кнопку "редактирование" (посередине в нижней строке экрана).
Префикс координат N или S - северная или южная широта,
E, W - восточная или западная долгота.
координаты вводятся седующим образом:
разделитель между градусами, минутами и секундами - минус или пробел;
десятичный разделитель градусов, либо минут либо секунд - точка.
Это позволяет вводить координаты в любом формате (градусы с долями / градусы,минуты,секунды / градусы и минутыс долями минут)
Примеры:
N59.76926 - 59.76926 градусов сев.широты
N60 30 00 - 60 градусов 30 минут 00 сек сев. широты
N60 20.89 - 60 градусов 20,89 минут сев. широы
После ввода координат нажать ">>" для дальнейщего выбора:
Старт - установить точку старта в заданные координаты (Если девайс находится в зоне приема сигнала GPS, необходимо предварительно отключить GPS в разделе Меню-Функции, в противном случае при определении своего местоположения программа установит точку старта в соответствии с GPS-данными).
Финиш - выбранная точка устанавливается как конечная точка маршрута.
Точка маршрута - выбранная точка является промежуточной точкой маршрута.
В закладки - Добавить выбранную точку в закладки.
Показать - Показать выбранную точку на карте. При этом выводится Окно предварительного просмотра.


Карта
Этот раздел меню предназначен для работы с картами.

Меню - выход в главное меню,
Поехали - выход из меню, возврат в режим просмотра карты.
Еще - следующие страницы раздела.


Открыть
Редактирование списка карт (атласа).
При выборе этого пункта программа анализирует свой каталог и его подкаталоги на наличие карт и показывает список доступных карт.
В списке можно выбрать карту и пометить ее галочкой (включить карту в атлас) или крестиком (исключить из атласа). Карты, исключенные из атласа, не учитываются при прокладке маршрута, даже если Ваше местоположение находится в пределах этой карты.

ВНИМАНИЕ! КАРТА "ДОРОГИ ЕВРАЗИИ" ДОЛЖНА БЫТЬ ВКЛЮЧЕНА ОБЯЗАТЕЛЬНО! Это необходимо для прокладки маршрута через несколько карт и для корректной работы адресного поиска.

"Загрузить" - принудительно открыть для просмотра выбранную карту, независимо от текущего местонахождения.
"Закрыть" - выход из меню, возврат в просмотр карты.

Внимание! Если в устройстве имеется несколько версий карты одного региона (например, официальная и OSM) - то в атлас следует включать только одну из них. Одновременное включение двух карт одного региона может привести к некорректной прокладке маршрута!


Слои
В данном разделе можно выбрать слои (категории объектов), которые будут отображаться на карте.
Список слоев двухуровневый. Для перехода к подкатегории слоев надо нажать кнопку "Выбрать", обратно - кнопку "Наверх".
Например, слои "АЗС", "Шиномонтаж", "Мойки" и т.д. находятся в категории "Автомобилистам".
Включить можно отдельные слои или всю категорию.
Данные слои внесены в карту разработчиком; пользователь редактировать списки слоев и объектов слоя (дополнять, удалять, изменять) не может.
Исключение - файлы радаров, которые располагаются в папке с картами.
Их отображение включается в разделе Слои-Дорожные знаки-Радары
"Закрыть" - Возврат в меню Карта.


Ночь (День)
Данная кнопка позволяет переключить карту и интерфейс в ночной (и обратно в дневной) режим. При переключении режима происходит выход из меню и возврат в режим просмотра карты.
Примечание: Если включено автоматическое переключение дневного и ночного режимов, то после выбора режима программа все авно атоматически переключит режим в зависимости от времени.
Таким образом, для корректного ручного переключения необходимо отключить автопереключение (Меню-Карта-Еще-Еще-Автопереключение день/ночь).


Вид-Карта / Вид-Перспектива
Данная кнопка выбирает режим отображения карты 2D ("плоский", или "вид сверху") или 3D ("перспектива", или "наклонный").
Действие данной кнопки полностью дублируется экранной кнопкой 2D/3D.
При выборе режима происходит выход из меню и возврат в режим просмотра карты.


Север сверху
Данная кнопка позволяет повернуть карту на экране так, чтобы север был сверху экрана.
После движения по маршруту (когда карта ориентирована по движению), при просмотре карты бывает трудно сориентироваться на карте. Для поворота карты используется кнопка "Север сверху". При этом происходит выход изм меню и возврат в режим просмотра карты.
Данная функция может включаться также нажатием на маленький серый значок с изображением компаса на экране.


Инфо
Данный пункт позволяет просмотреть следующие данные о программе и текущей (активной) карте:
Версия программы,
Карта (регион),
Версия карты и дата выпуска корректур,
Дата/время получения информации о пробках,
Номер лицензии,
Код устройства,
Код активации.
Эта информация понадобится при поиске неисправностей и при обращении в техподдержку.

Меню - Карта - Инфо

Меню - Возврат в лавное меню
Поехали - Возврат в режим просмотра карты.


Масштаб
В данном разделе меню можно выбрать масштаб отображения карты.
Закрыть - возврат в меню "Карта"


Автомасштаб
Данная кнопка включает и выключает автомасштаб.
Функция автомасштаба изменяет масштаб изображения карты при изменении скорости автомобиля. Включенный режим атомасштаба обозначается на экране красным цветом индикатора масштаба (выключенный - черным).
Параметры автомасштаба заданы в файле autoscalecfg.txt который находится в рабочей папке программы.
По умолчанию заданы следующие значения:

1 0 130
15000
15000
15000
18000
23000
28000
35000
45000
60000
90000
130000
180000
240000
240000

В первой строке числа 0 и 130 - скорости, соответствующие первой и последней строкам со скоростями. Учитывая количество строк, можно посчитать, что в данном примере от 0 до 30км/ч масштаб установлен 15000, дальше изменяется, а выше 120 - устанавливается масштаб 240000.

Для изменения значений по умолчанию Вы можете воспользоваться скриптом на сайте probki.net , генерирующим значения масштаба в зависимости от заданной скорости.

Полученные значения нужно сохранить (заменить) в файле autoscalecfg.txt.

В случае если автомасштаб включен и нажать кнопки увеличения или уменьшения (+/- основного экрана программы) это действие приведет к пропорциональному увеличению или уменьшению значений заданных в файле autoscalecfg.txt. Измененные значения сохраняются между сессиями программы.

Чтобы вернуть значения автомасштаба по умолчанию достаточно выключить и включить его в настройках программы Меню – Карта – Еще – нажать «Выключить автомасштаб»/«Включить автомасштаб».

Кроме того, существует Автомасштаб по маневру .


Еще
Лизензии карт - просмотр списка лицензий на карты. Кнопкой "получить" запускается подключение к сети и скачивание лицензий на имеющиеся карты. Эту операцию необходимо проделать, если при попытке загрузить лицензионную карту выдается сообщение "Error loading XXYYYY.dcm (2)".
Вид масштаба - изменение индикатора масштаба на экране (линейный - отрезок с обозначенной длиной, числовой - в виде 1:20000, нет - отсутствует).
Вид перспективы - выбор параметров отображения карты в режиме 3D (Перспектива)Ж
3D дома - отображение домов рельефными фигурами (реальная высота зданий не отображается)
3D развязки - отображение относительной высоты расположения путепроводов на развязках.
3D модели зданий - отображение моделей отдельных зданий с высотой, цветом, рисунком фасада и т.д.
Удерживать 3D при сдвиге - если эта опция включена, то при сдвиге карты она остается в режиме перспективы. Если выключена - то при сдвиге карты пальцем или кнопками карта показывается в режиме 2D (вид сверху). Для возврата в 3D режим надо нажать кнопку возврата (внизу экрана) - с изображением стрелки - курсора ("дельтаплана").
Выключенная эта опция очень удобна для возможности быстро просмотреть маршрут на несколько маневров вперед и вернуть 3D вид карты.
Наклон перспективы - выбор степени наклона карты в режиме "Перспектива". Точно так же этот параметр можно менять экранными кнопками наклона.
Автонаклон перспективы - режим автоматического изменения наклона перспективы при изменении скорости.
Контекстное меню - способ вызова контекстного меню (для операций с выбранной точкой на экране)
по клику - меню показывается сразу при касании карты на экране.
по длительному нажатию - меню показывается при длительном нажатии на экран, что позволяет избежать ложных вызовов меню при случайных касаниях экрана.
по кнопке - при касании экрана в выбранной точке показывается прицел, а внизу экрана - кнопка вызова контекстного меню с таким же прицелом.
Размер текста - размер надписей на карте. Подбирается индивидуально опытным путем.
Еще:
Названия улиц горизонтально - позволяет включить режим горизонтального расположения надписей, независимо от направления улицы.
Вращать карту по движению - вкл./выкл. режим, при котором поворачивается карта, а стрелка-курсор ("дельтаплан") направленва вверх экрана.
Полная прокрутка карты - когда эта функция включена, перемещение карты осуществляется плавно, не оставляя пустых зон на экране. При выключенной - сдвиг карты пальцем перемещает только ту часть карты, которая была на экране. остальная часть экрана остается незакрашенной, и карта переисовывается после отпускания экрана. Это позволяет ускорить работу программы.
Фото-развязки - вкл./выкл. отображение схемы въезда на развязку с расположением полос и направлением движения по ним.
Автомасштаб по маневру - вкл./выкл. режим автоподбора такого масштаба, при котором на экране будет видно текущее положение и следующий маневр.
Автопереключение день/ночь - автоматическое включение ночного и дневного режима. Режим переключается в определенное время (не связанное с восходом и заходом солнца), и не сбрасывается при ручном выборе режима день или ночь (в меню Карта). Перед ручным выбором режима следует убедиться, что автопереключение отключено.


Маршрут
Настройки работы с маршрутом.

Меню - выход в главное меню,
Поехали - выход из меню, возврат в режим просмотра карты.
Еще - следующие страницы раздела.


Показать маршрут
Показать весь маршрут на экране. При этом карта переводится в 2Dрежим. Это позволяет предварительно оценить проложенный маршрут, например - через центр города или по объездной, по каким мостам (особенно актуально в Санкт-Петербурге в период разводки мостов) и т.д. При необходимости можно скорректировать маршрут с помощью промежуточных точек.
Примечание - при просмотре всего маршрута целесообразно воспользоваться функцией " Север сверху ".


Удалить маршрут
Удалить все введенные точки маршрута (финиш, промежуточные точки и старт, если он был задан вручную).


Легенда
Легенда маршрута - показывает список поворотов, названия улиц и расстояние до них.
Легенда пролистывается автоматически, но можно проматывать ее вручную. Легенду можно также вызвать нажатием на индикатор ближайшего маневра на карте.
Очевидно, что команда "легенда" работает только при найденном маршруте.


Изменить маршрут
Редактирование маршрута.
В списке точек можно менять точки местами (изменяя, таким образом, очередность проезда точек), удалять точки, переименовывать их.


Загрузить маршрут
Просмотр списка сохраненных маршрутов.
Маршрут можно удалить, переименовать, или загрузить.
В сохраненный маршрут входят промежуточные точки и финиш, а точка старта устанавливается в текущее положение по GPS.
Сам путь объезда точек при загрузке прокладывается заново (с учетом пробок), однако порядок проезда промежуточных точек не меняется.
Один и тот же маршрут, загруженный в разное время, может быть проложен по-разному.


Сохранить маршрут
Заданный маршрут можно сохранить, чтобы в следующий раз не вводить все точки заново.
В сохраненный маршрут входят промежуточные точки и финиш.
Сам путь объезда точек при загрузке сохраненного маршрута прокладывается заново (с учетом пробок). Таким образом, один и тот же маршрут, загруженный в разное время, может быть проложен по-разному.


Проиграть маршрут
Эта функция (симуляция маршрута) позволяет посмотреть, как будет выглядеть на экране движение по выбранному маршруту.
Скорость "виртуальной" поездки можно менять нажатием насимволы "+" и "-", которые в этом режиме появляются на экране.


Объезд
Эта команда принудительно устанавливает на ближайшем ребре (после ближайшего маневра) скорость 1 км/ч. Эта скорость действует только для одного пользователя, на сервер не передается. В результате программа предложит ехать по этой дороге только в том случае, если других путей нет.


Еще
МАРШРУТ - Еще
Удалить точку - удаляет первую в списке промежуточную точку.
Следующая точка - выход из меню, переход в режим просмотра карты, с отображением следующей промежуточной точки.
Предыдущая точка - выход из меню, переход в режим просмотра карты, с отображением предыдущей промежуточной точки.
Надо отметить, что эти три функции использовать практически невозможно, гораздо удобнее это делать через Меню-Маршрут-Изменить маршрут.
Тип - выбор типа маршрута:
Оптимальный - основной - маршрут прокладывается из расчета минимального времени доезда с учетом запретов, ограничений, односторонних дорог и т.д.
Кратчайший - маршрут минимальной длины, независимо от пробок.
Экстренный - игнорирует пробки, запреты, ...
Пешеходный - игнорируются пробки, запреты, односторонние дороги
Внедорожный - путь между точками прокладывается по прямой.
На практике использоваться может только Оптимальный тип маршрута.
Цвет - выбор цвета линии маршрута. Например "желтый на синем" - желтые стрелки на синей линии.
Пересчет маршрута при удалении более... - задается расстояние, считающееся погрешностью определения координат GPS. Если точка текущего положения отдалилась от маршрута на большее расстояние - маршрут прокладывается заново, от текущего положения.
Использовать файл ограничений - данная функция до сих пор толком нигде не описана, за исключением того, что "можно установить дополнительные ограничения например для грузового транспорта". Однако о формате данного файла и способах его создания науке ничего не известно.


Пробки
Настройка получения и отображения информации о пробках.

Меню - выход в главное меню,
Поехали - выход из меню, возврат в режим просмотра карты.


Отключить/включить пробки
Включение/выключение пробочного сервиса.
При отключении программа не отсылает данные о своем движении и не загружает информацию о пробках.
Эта функция может быть полезна для снижения расходов на GPRS-интернет, особенно в роуминге.
Кроме того, отключать "пробки" требуется для корректировки запретов в режиме " Правка "


Вид пробок
Нет - скорости потока по улицам не показываются (но учитываются при маршрутизации)
Цветные линии - скорость обозначается цветной линией вдоль улицы (красный - пробка, зеленый - свободное движение).
Значения скорости - значения скорости написаны в светных полукругах, прилегающих к улице. Из-за сходства с поросячьим ппятачком их называют "хрюшками"
Линии и скорости - скорость надписана цифрами рядом с цветными линиями.


Обновить
Принудительно получение информации о пробках. В нормальном режиме программа получает информацию каждые 3 минуты, свои данные отправляет каждую минуту.


Инфо
Данный пункт позволяет просмотреть следующие данные о программе и текущей (активной) карте:
Версия программы,
Карта (регион),
Версия карты и дата выпуска корректур,
Дата/время получения информации о пробках,
Номер лицензии,
Код устройства,
Код активации.
Эта информация понадобится при поиске неисправностей и при обращении в техподдержку.

Меню - Пробки - Инфо

Меню - Возврат в лавное меню
Поехали - Возврат в режим просмотра карты.


Правка
Этот раздел позволяет просматривать и изменять корректуры.
Предваритедльно следует отключить пробки (Меню-Пробки-Отключить пробки).
Одностороннее движение - включает отображение односторонних движений.
Запреты поворотов - включает отображение запрещенных поворотов.
Скорость потока - показывает скорость потока по умолчанию для улиц (скорость, которая приписывается данной улице, если данных о движении по ней нет). Снижение этой скорости понижает вероятность, что программа будет предлагать объезд пробки по этой улице. Установив скорость 0, можно полностью запретить прокладку маршрута по этой улице.


Интернет
Имя - Имя пользователя (login), под которым программа зарегистрирована на сайте probki.net (то есть имя, под которым скачиваются обновления).
Пароль - пароль пользователя. При нажатии "Изменить" пароль становится видимым, что позволяет Вам вспомнить его, если Вы не помните, под каким паролем надо скачивать обновления карт/программы с сайта probki.net.
Подключаться к сети - разрешить программе устанавливать подключение к Интернету для получения информации о пробках. Если отключить эту функцию и принудительно разорвать интернет-соединение, программа не сможет получать информацию о пробках. Это целесообразно при нахождении в роуминге.
Удерживать соединение при выходе из программы. Позволяет экономить трафик при последующем повторном входе в программу. Особенно полезно, если программа используется короткими сессиями, а сотовый оператор тарифицирует трафик большими пакетами (от 100 кБ).


Отключить вопрос о пробке
Вопрос о пробке задается, если пользователь задержался на ребре слишком долго (и есть вероятность, что он не стоит в пробке, а остановился на заправке, у магазина и т.д., а программу не выключил). Если пользователь не хочет получать постоянные вопросы "отправить сообщение о пробке?", можно этот вопрос отключить.


Важно
Очень рекомендуется хотя бы один раз прочитать этот пункт меню, это действительно важно!


Сообщения
Отправка сообщений о DPOI

Плохая дорога - дефекты дорожного покрытия, представляющие серьезную опасность при движении.
SOS - (пока не реализовано)
Проезд закрыт - ремонтные работы, затрудняющие проезд.
ДПС - мобильный патруль, переносной радар - не путать со стационарным постом!!!
Эвакуатор - работает эвакуатор, следует внимательнее смотреть на знаки, выбирая место для парковки.
ДТП - произошла авария, затрудняющая движение.
Опасность (открытый люк, упавшее дерево, оборванный провод контактной сети и т.д.)

Динамические POI (DPOI, ДПОИ) - объекты, временно присутствующие на дороге. Чтобы отметить такой объект на карте, надо отправить соответствующее сообщение из этой точки. Данная отметка появится на карте у других пользователей. При расчете маршрута они не учитываются, но выдается голосовое предупреждение (только о тех объектах, которые выбраны в пункте Активные сервисы).
Координаты точки запоминаются не в момент выбора сообщения, а при входе в меню. То есть, чтобы отметить ДТП, надо, проезжая мимо него, войти в меню, а далее, в более спокойной ситуации (например на светофоре) войти в "Сообщения" и выбрать "ДТП".

Текст - отправить текстовое сообщение пользователю СитиГИДа, по его логину (имени пользователя). В настоящее время координаты текущей точки или заданного финиша в сообщение не вставляются, таким образом полезность этой функции весьма сомнительна.

Еще - Дополнительные параметры:
Входящие, Исходящие - для обмена текстовыми сообщениями с другими пользователями СитиГИДа.

Объекты мониторинга - Позволяет осуществлять Мониторинг друзей. Необходимо узнать у друга номер его лицензии, и ввести этот номер и имя, под которым друг будет отображаться на Вашей карте. У друга для этого необходимо также включить функцию Диспетчер (см.ниже).
Контакты - список телефонов техподдержки СитиГИД
Использовать сервисы - вкл./выкл. сервисы сообщений и DPOI. Применяется пдля снижения или исключения GPRS трафика в роуминге.
Активные сервисы - выбор DPOI, информацию о которых следует загружать и отображать. Кроме того, в списке сервисов есть Диспетчер. Его необходимо включить, чтобы другой пользователь мог видеть Ваше положение с помощью функции Мониторинг друзей.
Внимание - сервис Диспетчер отправляет свои координаты чаще, чем сервис пробок, поэтому при включении Диспетчера трафик возрастает!


Функции
Дополнительные функции и служебные команды

Меню - Функции

Меню - возврат в главное меню
Поехали - выход из меню, возврат на карту


Отключить/Включить GPS
Отключить/Включить GPS - отключает GPS приемник. Имеет практический смысл в следующей ситуации: пользователю надо проложить маршрут из точки A в точку B, причем сам он находится не в точке A, а в точке C или B. При включенном GPS приемнике старт маршрута будет автоматически переноситься в точку текущего положения. Так что перед установкой точки старта надо отключить GPS приемник.


Стоянка
Стоянка - устанавливает режим "стоянка", в котором сведения о собственной скорости игнорируются и на сервер не отсылаются. Этот режим позволяет избежать образования "ложных пробок" из-за того, что кто-то остановился на 10 минут. Очень рекомендуется настроить эту функцию на апаратную кнопку устройства и не лениться использовать ее при остановках.
Режим «Стоянка» отменяется автоматически при достижении вашим транспортным средством скорости более 20 км/ч.


Свернуть
Свернуть - сворачивает программу, не закрывая ее. Полезно, если надо позвонить или воспользоваться другими функциями КПК, не выключая программу. (Особенно начиная с версии 3.7, которая работает только в полноэкранном режиме)


Снимок экрана
Снимок экрана - (скриншот) - сохраняет файл BMP, содержащий копию изображения на экране. Скриншоты нужны для пояснения описания ошибок программы/карты при обращении в техподдержку или к другим пользователям на forum.probki.net.
Снимки экрана хранятся в папке CityGuide\Screenshots, в корневом каталоге устройства или карты памяти (в зависимости от того, куда Вы установили программу).


Дорожный компьютер
Дорожный компьютер - малополезная функция. Показывает пройденное расстояние, среднюю скорость и расход горючего за текущий сеанс пользования прграммой, с момента последнего сброса показаний маршрутного компьютера (с отметки), и за все время.

Дорожный компьютер - Еще

Еще - настройка маршрутного компьютера:
Расход по трассе и
Расход по городу - задаются для оценки расхода, причем задаются только целыми числами.
Стоимость литра топлива - для оценки затрат на горючее.
Сбросить отметку - сбросить показания, начать учет (в графе "с отметки") с нуля.


Отключить/Включить запись трека
Отключить/Включить запись трека - При включенной записи программа постоянно сохраняет файл трека - данные о положении в определенные моменты времени. В трек сохраняются данные (координаты), полученные от приемника GPS, не скорректированные (не приведенные к дороге). Треки могут понадобиться для обращения в техподдержку - если трек стабильно идет мимо дороги, или перекресток не совпадает с траекторией трека, то файл трека следует приложить к сообщению, отправленному картографам.
Треки хранятся в папке CityGuide\Tracks, в корневом каталоге устройства или карты памяти (в зависимости от того, куда Вы установили программу).


Список треков
Список треков - выводит список сохраненных треков.
Проиграть - симулировать движение по маршруту выбранного трека.
Загрузить - показать трек на карте. Позволяет оценить точность привязки дорог на карте к координатам.
Закрыть - Возврат в меню "Функции".


Помощь
Помощь - текстовый файл с подсказками по основным возможностям программы. На данный момент неактуален, так как составлялся для предыдущих версий.


Настройки
Настройки программы

Меню - Настройки

Меню - возврат в главное меню
Поехали - выход из меню, возврат на карту
Еще -
По умолчанию - загрузить настройки по умолчанию


Быстрый доступ
Настройка кнопок меню быстрого доступа ("быстрое меню", "квик-меню", "quick-menu").
Нажатие на любую кнопку меню вызывает список доступных функций, которые можно назначить на эту кнопку для быстрого вызова.
Меню - Возврат в главное меню
Поехали - выход из меню, возврат в просмотр карты
Закрыть - возврат в меню "Настройки"


Фавориты
Настройка списка Фаворитов (избранных закладок).
Нужно нажать кнопку, которую хотим использовать, и в открывшемся списке закладок выбрать нужную.
Идентично меню Фавориты-Настроить .
Примечание - поскольку название кнопки берется из названия закладки, рекомендуется заботиться о том, чтобы закладки имели достаточно короткие имена (1-3 слова), чтобы помещались на кнопке, и желательно крупными буквами (для лучшей читаемости). Вместо названий типа "Иванов-дача" предпочтительнее использовать "ИВАНОВ ДАЧА", так как название с пробелом будет корректно перенесено по словам на кнопке.


GPS
Настройки получения информации от GPS приемника.
COM-порт - номер COM-порта (зависит от устройства).
скорость - скорость передачи (зависит от устройства).
Если настройки GPS приемника неизвестны, следует отключить GPS (Меню-Функции-Отключить_GPS), выставить в поле COM-порт значение "Нет", и включить GPS (Меню-Функции-Отключить_GPS). При этом запустится автопоиск GPS.
Синхронизировать время по GPS - настройка времени по сигналам спутников.
Эта функция необходима для навигаторов, сбрасывающих показания часов в выключенном состоянии. Для этого в настройках устройства необходима выставить часовой пояс. Точное время необходимо для правильного получения информации о пробках.
Включать GPS при старте - Включение GPS приемника при запуске программы.
Приостанов при свертке программы - отключение GPS приемника при свертывании окна программы.
Рестарт при потере сигнала -
Вкл./Выкл. Bluetooth


Экран
Настройки отображения информации на экране.

Язык - выбор языка (вступит в силу после перезапуска программы).
Вид интерфейса - позволяет выбрать один из двух интерфейсов (скинов) - Упрощенный использует немного меньше графики, за счет чего несколько ускоряет работу.
Дневной вид панели навигации - выбор панели навигации (темный фон/светлые буквы или наоборот).
Меню на старе - включает/выключает показ стартового меню. Лучше отключить, чтобы при запуске программы сразу показывалась карта.
Размер экрана и Детализация карты - эти два параметра позволяют подобрать удобные размеры надписей на карте, значков POI и т.д. Подбираются опытным путем.
Показ скорости - вкл./выкл. отображение значения текущей скорости на экране.
Показ времени и даты - вкл./выкл. отображение текущих даты и времени на экране.
Показ иконки в Windows - позволяет при свертывании программы быстро вызвать ее с помощью значка на экране.


Кнопки на экране
Масштабирование
Наклон перспективы
Эти пункты позволяют отключить выбранные экранные кнопки, во избежание случайных нажатий.
Скрыть экранные кнопки - скрывает все экранные кнопки, при этом они по-прежнему работают (если не отключены двумя предыдущими пунктами).
Скрывать нижнюю панель - автоматически убирает с экрана кнопки нижней панели (Финиш, Quick, DPOI), для вызова их на экран используется кнопка "Меню"


Голосовые сообщения
Настройка звуков:

Меню - Настройки - Голосовые сообщения

Громкость - регулировка громкости.
Перед маневром - задает время (1-5 сек), за которое программа должна предупредить перед маневром.
О приближении к объекту - задает расстояние, за которое программа должна предупредить о приближении к выбранным объектам (см.Меню-Поиск-Места интереса).
А также - выбор дополнительно голосовых уведомлений о приближении к постам ДПС, камерам и АЗС.
При изменени маршрута - Вкл./Выкл. уведомления о пересчете маршрута ("Найден новый маршрут".
При сбое связи с сервером - Вкл./Выкл. уведомления "Ошибка связи с сервером".
Звук при нажатии - Вкл./Выкл. щелчка при нажатии на экранные кнопки.


Клавиатура
Выбор типа клавиатуры:
Системная,
Полная АБВ (буквы в алфавитном порядке)
Полная ЙЦУКЕН (буквы в стандартном порядке, как на клавиатуре ПК)
Телефонная (крупные кнопки, несколько букв на каждой, как на телефоне).


Горячие клавиши
Назначение горячих (аппаратных) клавиш.
Выбрать нужную функцию и нажать кнопку аппарата, на которую следует назначить эту функцию.
В варианте интерфейса "Упрощенный" эту функцию ошибочно удалили.
Чтобы назначить аппаратные клавиши, следует перейти в интерфейс "Стандартный" или воспользоваться альтернативным скином.


Еще


.topic 770

Окно предварительного просмотра позволяет оценить на карте, правильно ли найден объект. Если найден не тот объект, можно нажать << и вернуться к выбору объекта из списка. Если  же все устраивает - кнопкой "Поехали" можно вернуться на карту.


CityGuide

Окно предварительного просмотра позволяет оценить на карте, правильно ли найден объект. Если найден не тот объект, можно нажать << и вернуться к выбору объекта из списка. Если же все устраивает - кнопкой "Поехали" можно вернуться на карту.